We are pleased to announce that we are now offering PHP 5.3 for shared hosting as well the 5.2 version. We have been supporting 5.3 on our VPS accounts and it has proven to be reliable and stable so now when you sign up for shared hosting you can pick which version of PHP you want. Pricing for hosting with PHP 5.3 is the same as the other versions. While some PHP Hosting companies are offering PHP 5.3, many are offering it as a CGI, we tested this option and due to performance reasons we decided to dedicate a whole server to PHP 5.3. The downside is that you can’t run 5.2 and 5.3 on the same machine, the upside is that it’s freaking faster this way. Current ServerGrove customers can migrate to PHP 5.3 free of charge. Just give support a shout and request that your hosting account be migrated to a 5.3 server.

PHP 5.3 has a number of new features released, including:

and more. The full list can be viewed here http://php.net/releases/5_3_0.php

PHP 5.3 is specially good for sites and applications developed with frameworks like symfony and Zend Framework, as they run much faster thanks to the improved memory management. Additionally, the new branches PHP frameworks like Symfony2, Lithium and Zend Framework 2.0 will only run on PHP 5.3 and above.

Please keep in mind that some PHP scripts and applications that were developed on older versions of PHP may not run with PHP 5.3, so it is always a good idea to test and make sure everything works correctly.